Howto install the Audiodriver for an Amilo Si1520 on Windows XP Professional


Add comments

The Fujitsu Siemens Amilo Si 1520 contains a Conexant High Definition Audio Chip called CX20549. The notebook comes with a preinstalled Windows XP Home.

I installed the Professional version of Windows XP but the audio driver did not work.

The support hotline told me that this notebook and the audio driver only works with XP Home. Of cause, this is totally wrong, because all versions of Windows XP use exactly the same driver architecture.

After a little bit of research I found the ALB R14 notebook with the same audio chip. There was also a hint to the Microsoft knowledge base article 888111. Unfortunately the hotfix in this article is not available for download. But the driver package for the ALB R14 notebook contains the hotfix.
After installing the hotfix everything was fine. The audio and also the fax modem works. I think the preinstalled version of XP Home is already patched with this hotfix. Too bad that nobody from the support desk can tell.

31 Responses to “Howto install the Audiodriver for an Amilo Si1520 on Windows XP Professional”

  1. Roger Says:

    Nice job. I’ve bought one Si 1520 with XPHome also, and it was making me crazy with WinXPPro and the Conexant Audio driver. Well done Benjamin. Thanks very much.

  2. Rui Rocha Says:

    Hi, great info, i was almost crazy with the solution of this trouble. By the way, the graphic card is working well on win XP Pro? Sometimes it has a strange behaviour, like the luminosity is always changing?? And some other times (few) the screen start to move, like some interference is happening, and i’ve to close the cover and then open it again, and everything is ok again!! If you have any hint to that question, can you please answer me to my e-mail!!..

    Thanks,

    Ang Great info!!

  3. Churchyard Says:

    Thanx! You saved a weeks work! May you always find a solution!

  4. Elena Mueller Says:

    Thanx very much ! I’ve wasted one day for this shit problem

  5. Xem Says:

    THANK YOU! :D This was getting bit too frustrating.. you saved my day big time =)

  6. Stephan Says:

    Kicked the preinstalled Vista and installed XP. Wondered why FSC puts a driver on the download page that does not work, then found your solution. Thanks very much for saving me time and frustration !!!

  7. artiwal Says:

    Hi All!
    Unfortunetely I have the some problem and this article is not solving my issue. I have FS amilo si 1520, I get it with Vista and I have installed XP Pro, I cannot install modem and audio card, I have instaled this hotfix 888111 erier and I cannot install drivers from FS support site, conaxent site so I have downloaded this package, I have instaled this hotfix from this file and this driver and still Im getting response: FALUE
    f…
    Any ideas? Im going crazy

  8. Andreas Bartzsch Says:

    Hi,
    remove the yellow marked device from windows hardware manager… Execute the hotfix again and install the hxfsetup from the driver package.
    After all it should work correctly!!!

  9. Hermann Says:

    works also with amilo pro v series 3205! thank you very much, man!!
    grüsse
    Hermann

  10. artiwal Says:

    Unfortunetely there is no yellow marked device in device manager, it looks like system is not detecting this device at all :(

  11. Djzleite Says:

    Many thanks for this solution, downloaded the driver from fujitsu and wasn´t fiting so i googled and found this precious information right here, thanks for sharing it with the world.
    My Amilo came with vista but also running slow, installed XP SP2 and now all fine excluding this sound driver wich is now solved.

  12. Jan Says:

    hi,

    yes, superb solution.

    I still have the problem of luminosity still changing… also with vista, i tried.
    Anybody has this to?

  13. mex Says:

    hi,

    how do you turn off the spdif-output? under vista it was possible but now it istn´t and now the red light is on all the time… the realtek software works only under vista… i didn-´t find a software for xp yet.

    tanks, mex

  14. Benjamin Says:

    @mex

    i did not turn the spdif off under xp and by now i’m using vista. i did not know that it can be turned off. please tell me how to turn it of under vista :)

    tanks,
    benjamin

  15. mex Says:

    under vista its very easy: you can turm it off in the normal sound menu (volume). there should be in the drop-down field a option with digital audio output (something like that)…

    in the meantime i also found out, how it works under xp… :-)

  16. Benjamin Says:

    @mex

    for some reason i can not turn it of the way you said. but it’s no problem, it is only a small red light.

    but tell all the folks her using xp how to turn it off with that operating system.

  17. Tsilev Says:

    hey there, i just bought my amilo Si1520 and as everybody on that page i have problem with the audio driver. i lookd through the hotfix, i even installed it correctly, but still the yellow marks appear and it is searching for a driver:( i still don’t have any sound, so if somebody can help me, i would appreciate it. 10x

  18. Benjamin Says:

    @Tsilev

    did you install the driver AND the hotfix from the driver package? you have to install both becaus the driver needs the hotfix to be enabled

  19. Arban Says:

    Is working!

    Run the hotfix exe and then the setup of the driver.

    Restart.

    U r done.

    Thanx 4 sharing! I was like wtf is wrong with it..

  20. awkaman Says:

    I couldnt run the hotfix its requeting for a disk and finally gave error 110. also the site for hotfix didnt request for password during download as sent in my box. I have to make sure the audio works as its working for others

  21. tb.genius Says:

    pleas hint me if you want sound on your amilo si 1520

  22. Sjaak Says:

    Windows SP3 solves all the problems no hotfisex required!

  23. Sjaak Says:

    offcoure i meant HOTFIXES!

  24. daniel Says:

    hi people!

    the link to the driverpackage is not aktiv…unfortunatly i didn´t find this package from alb r14 notbook. i hope you can help me

    thanks, daniel

  25. Benjamin Says:

    @daniel

    I cannot tell how to get the audio running with XP. I’m now using Windows 7 on my Si1520 and I don’t see any reason to use XP anymore. Actually I’m always surprised how many people comment to this article.

    Anyway – The driver download is dead but the Microsoft KB article now links to a patch for Windows 2003 but the article itself applies also to XP. I would try that patch but I’ve no idea if it will work.
    Or just google for that patch somewhere.
    Or look at Sjaak’s comment above. Try SP3. If the SP works please confirm it as a comment for all other people still using XP on the Si1520.

  26. daniel Says:

    it is because i am using linux, and i only need win for several grafik things, so win7 wastes diskspace for my needs in win….trying the patch, i´ll see otherwise i think i have to install xp home

    anyway thank you for your help

  27. Bowman69 Says:

    Hello All!
    Have you found drivers for AMILO Si 1520 for Win 7 32bit? I just installed Win 7 Pro 32bit and all works except for 2 odd system devices that I can’t find a driver for..

    Any ideas?

    Thx!

    **Bowman69**

  28. Dave Says:

    hey benjamin…
    good work ur doing bud, just one question –
    i’m running xp home on my amilo si1520 and am experiencing the same symptoms. things aren’t looking up man! which link did you use or model/version alb r14 driver did you download, and where from?
    cheers

  29. a_polo2 Says:

    alguien podria poner el enlace del controlador de audio para el amilo si 1520 para windows xp profesional, estoy loco bucandolo y no lo encuentro. Gracuas

  30. Jarle Says:

    I have a amilo si 2636 windows 7 with Conexant HD Smart Audio 221, i only get sound with usb headphones, no sound on jackouput or speakers. No error in device manager. The sound meter in mixer shows sound is playing both for speakers and jackoutput, but no sound comes out. Any clue?

  31. Christen Pihl Says:

    A lot of thanks for all your work on this blog. My mum really likes working on research and it’s obvious why. Most people learn all relating to the compelling means you render important guidance via the web site and therefore encourage contribution from the others about this article and our simple princess is really becoming educated so much. Have fun with the rest of the year. You’re performing a terrific job.

Leave a Reply

WP Theme & Icons by N.Design Studio
Entries RSS Comments RSS Log in