msi-installer and RemovePreviousVersions-option fixed in Visual Studio 2008

Tags: , ,
Add comments

Visual Studio 2005 had a known issue with the setup project and the RemovePreviousVersions option if the version number of your software is less than 1.0. This was a problem for me every time I released a new version of PhotoTagStudio. Like most small open source projects I won’t call it 1.0 (the current version is 0.7).

I described the problem and a workaround using the tool orca.exe. Every time I build a new setup I had to patch the setup. Last week I switched my PhotoTagStudio project to Visual Studio 2008 and created a new release. While patching the created msi I discovered that there is no need to do it that way any more. The problem seems to be fixed in the Visual Studio 2008 release!

Great work Microsoft!

One Response to “msi-installer and RemovePreviousVersions-option fixed in Visual Studio 2008”

  1. Ticklish Techs » Blog Archive » msi-Installer created with Visual Studio and the RemovePreviousVersions-Option Says:

    [...] [Edit: this seems to be solved in Visual Studio 2008. See this article] [...]

Leave a Reply

WP Theme & Icons by N.Design Studio
Entries RSS Comments RSS Log in